
BLM442 Keşif aktivitesi-1: Elektronik tablo / Excell veri analizi ve görselleştirme 
 
 

 

İsim/Soyisim: Türkücan Erdem 

Öğrenci Numarası: 150202079  

E-mail: turkucanerdem@gmail.com 
 
İntihal: Netten alınacak kısmi kod parçaları önceden kod içinde/raporda belirtilmek ve soru 
sorulduğunda cevaplanması durumunda sıkıntı çıkarmayacaktır. (i) Internet kaynağını 
belirtmeyen/açıklayamayan/üzerinde geliştirme yapmayan veya (ii) birbirleriyle benzer/aynı çalışma 
teslim edenlerin aktiviteleri sıfır üzerinden değerlendirilecektir. 
 
 
Not: Her problem ve cevabı kendi sayfasında olacaktır. 
 
 
Kullanılan veriseti/spreadsheet adı:  Premier League 
 
Veriseti içerik açıklaması: Results of each match and stats of each team from season 
2006/2007 to 2017/2018 
 
Verinin alındığı Internet kaynağı: https://www.kaggle.com/zaeemnalla/premier-league 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
 
Problem 1 

Takımları 2006/2017 sezonundan 2017/2018 sezonuna kadar 
takımların evinde oynadığı maç sayısına göre sıralayınız. 
 
 
 
* Result veri seti seçilir. 
* Result veri setinde tüm veriler seçilir. 
* Data->Sort: 
* Sort by home_team sort on values A to Z. 
* Bu oynan maçtaki home teamleri isim sırasına göre dizer. 
* A column’u seçilip Data->Advanced’e gelip copy to another location’ı işaretleyip copy to G:G yazıp  
unique records only’i işaretleyince G ‘ye takımların unique listesini kopyalar 
(kaynak: https://www.techrepublic.com/blog/microsoft-office/generate-a-list-of-unique-entries-in-an-
excel-column/) 
* G2 hücresine gelinip “=COUNTIF(A:A,G2)” formülü girilir. Bu girilen formül “A’daki G2 değerine eş 
olan hücre sayısı” anlamına gelmektedir.  
* Bizim durumumuzda bu takımın kaç maç oynadığını verir.  
* Daha sonra bu hücreyi seçip aşşağıya kadar seçip mouse’u aşşağı sola çekip automatic cell 
numbering yaparız. 
* Automatic cell numbering’inden sonra takımların kaç maç oynadığını bulmuş oluruz. 
* G ve H hücrelerini seçip Data->Sort’a gelip “Sort by match numbers on values  largest to smallest”’ı 
seçeriz. Bu en fazla maç oynayan takımlardan en az maç oynayan takımlara kadar sıralar. 
 
Sonuç: 

home_team match number 
Arsenal 228 
Chelsea 228 
Everton 228 
Liverpool 228 
Manchester City 228 
Manchester United 228 
Tottenham Hotspur 228 
West Ham United 209 
Aston Villa 190 
Newcastle United 190 
Stoke City 190 
Sunderland 190 
West Bromwich Albion 171 
Fulham 152 
Swansea City 133 
Wigan Athletic 133 
Blackburn Rovers 114 
Bolton Wanderers 114 
Southampton 114 
Crystal Palace 95 
Hull City 95 

https://www.techrepublic.com/blog/microsoft-office/generate-a-list-of-unique-entries-in-an-excel-column/
https://www.techrepublic.com/blog/microsoft-office/generate-a-list-of-unique-entries-in-an-excel-column/


Burnley 76 
Leicester City 76 
Middlesbrough 76 
Norwich City 76 
Portsmouth 76 
Watford 76 
AFC Bournemouth 57 
Birmingham City 57 
Queens Park Rangers 57 
Reading 57 
Wolverhampton 
Wanderers 57 
Blackpool 19 
Brighton and Hove 
Albion 19 
Cardiff City 19 
Charlton Athletic 19 
Derby County 19 
Huddersfield Town 19 
Sheffield United 19 

  
  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
 
 

Problem 2 

Problem 1’de sıralanan takımlardan evinde en çok 10 gol atmış 
takımı sıralayınız. 
 
 
 

• I row’una toplam gol ismi verilir 
• G H ve I rowları seçilerek Data->Sort seçilir, “sort by home team sort on values order to A to 

Z” seçilerek toplam atılan gol sayısından takımların ismine göre geri sortlarnır. 
• I2 hücresine “SUMIF(A:A,G2,C:C)” formülü girilir.(Kaynak: https://exceljet.net/formula/sum-

if-cells-contain-specific-text) 
• Yukarıda verilen formül “Eğer AX hücresinde yer alan text G2 hücresinde yer alan text ile 

eşitse bu sıradaki CX hücresini toplama ekle” anlamına gelir 
• Bu ise bizim durumumuzda “Eğer takım ismi hücredeki aynıysa attığı gol sayısını ekle” 

anlamına gelir.  
• Takım isimlerine göre sıralanmış attığı gol sayısını buluruz 
• G,H ve I seçilir, Data->Sort a gelinir “Sort by toplam gol sort on values order largest to lowest” 

seçilir. Bunun sonucunda tüm takımları attığı gole en fazladan en aza doğru sıralar. 
• Daha sonra G,H ve I tekrardan seçilip  Filter’a tıklanır. Toplam gol’e gelip tıklanıp “Top 10 

seçilir” 
 
 
Sonuç: 
 

season home_team match number toplam gol  
2015-
2016 Manchester City 228 501  
2015-
2016 Manchester United 228 495  
2015-
2016 Chelsea 228 491  
2015-
2016 Arsenal 228 479  
2015-
2016 Liverpool 228 466  
2015-
2016 Tottenham Hotspur 228 422  
2015-
2016 Everton 228 395  
2015-
2016 West Ham United 209 286  
2015-
2016 Newcastle United 190 268  
2015-
2016 Stoke City 190 248  

 
 
 



 
 
 

Problem 3  

Her sezon için atılan gol sayısını bulunuz. 
 
 
 

• F seçilir. Data->Advanced filter seçilir. 
• Advanced Filter’dan “ Copy to another location” seçilir, copy to J:J girilir, “Unique records 

only” tiklenir. 
• J de düzenlenmemiş olarak unique sezonlar çıkar.  
• J2den  J14’e kadar seçilir.  Data->Sort seçilir. “Sort Column J, Sort on Values Z to A” seçilir. 

2017-2018’den  2006-2007 ye kadar azalarak listelenir. 
• K1’e “Toplam Gol” toplam gol girilir. 
• K2’ye “=SUMIF(F:F,J2,C:C)” formülü girilir. “F’den F’e kadar J2’ye text olarak eşit olan 

sıralardaki C değerleri toplanır.”  
• 2017-2018 için  582 değeri çıkar. K seçilir, automatic cell numbering yapılır. Bunun 

sonucunda yukarıdaki formül diğer sezonlar için uygulanır. 
 
 
 

Sonuç: 
 

season toplam gol    
2017-2018 582    
2016-2017 607    
2015-2016 567    
2014-2015 560    
2013-2014 598    
2012-2013 592    
2011-2012 604    
2010-2011 617    
2009-2010 645    
2008-2009 532    
2007-2008 581    
2006-2007 552    
     
     

 
 
 
 
 
 
 
 
 
 
 
 



 
 

Problem 4 

Takımların kariyerleri boyunca evinde kaç kere berabere kaldığını 
bulunuz 
 
 

• Tüm tablo seçilir. 
• Insert->Pivot Table seçilir. 
• Yanda çıkan “ PivotTable Fields” kısmından “home_team” ve “result” seçilir. 
• Home_team row kısmına atanır.  
• Result  Values kısmına atanır. Oluşan tabloda takımların Premier Lig’de kaç kere sonuç 

aldığı yani kaç kere maç oynadığı çıkar. 
• Daha sonra B1 hücresinde bulunan kısıma gelip filter “All” dan “D” yani draw’a çekilir. 
• Oluşan tabloda takımların kariyerleri boyunca kaç kere berabere kaldığı çıkar 

 
Sonuç: 
 

Row Labels 
Count of 
result  

AFC Bournemouth 14  
Arsenal 50  
Aston Villa 61  
Birmingham City 25  
Blackburn Rovers 31  
Blackpool 5  
Bolton Wanderers 30  
Brighton and Hove Albion 8  
Burnley 20  
Cardiff City 5  
Charlton Athletic 5  
Chelsea 52  
Crystal Palace 16  
Derby County 5  
Everton 59  
Fulham 36  
Huddersfield Town 5  
Hull City 24  
Leicester City 21  
Liverpool 65  
Manchester City 37  
Manchester United 31  
Middlesbrough 23  
Newcastle United 52  
Norwich City 24  
Portsmouth 19  
Queens Park Rangers 18  
Reading 12  



Sheffield United 6  
Southampton 33  
Stoke City 54  
Sunderland 55  
Swansea City 37  
Tottenham Hotspur 50  
Watford 25  
West Bromwich Albion 45  
West Ham United 51  
Wigan Athletic 42  
Wolverhampton Wanderers 13  
Grand Total 1164  
   
   
   
   
   
   

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
 

Problem 5 

Sezon başına gösterilen kırmızı kart sayısını bulunuz 
 
 

• Stats veri seti seçilir. 
• Results veri setinde yaptığımız işlemlerden oluşan G’den L’ye kadar olan kısım kopyalanarak 

Stats veri seti ile birleştirilir(joining), Stats veri setinde AQ-AU arasına kopyalanır 
• AV1’e “Kırmızı kart” girilir. 
• AV2’de function kısmından “SUMIF” seçilir. Range kısmına hangi sezon oldugunu belirten 

kısım olan AP:AP girilir. Criteria kısmına ise istediğimiz sezon yani diğer veri setinden 
birleştirdiğimiz AT kısımından AT2 girilir. Sum Range kısmına ise takımın sezon başına 
yediği kırmızı kartı gösteren F:F kısmı verilir. 

• AV2 de çıkan sonuca göre 2017-2018 sezonunda  39 kırmızı kart gösterilmiştir. Daha sonra 
tüm sezon boyunca indirilerek automatic cell numbering yapılır.  

• Çıkan tablo bize sezonda gösterilen kırmızı kart sayısını gösterir. 
 
 
Sonuç: 
 
season Kırmızı kart 
2017-
2018 39  
2016-
2017 41  
2015-
2016 59  
2014-
2015 71  
2013-
2014 53  
2012-
2013 52  
2011-
2012 66  
2010-
2011 65  
2009-
2010 68  
2008-
2009 63  
2007-
2008 59  
2006-
2007 51  
   

 
 



 
 

Problem 6 

Her sezon için gösterilen kırmızı kart için gösterilen sarı kart sayısını 
bulunuz 
 
 

• Problem 5’deki işlemi devam ettirip bu sefer sarı kart sayısını bulmaya çalışırız. 
• AW1’e “Sarı kart” ismini veririz. 
• AW2’ye formula SUMIF(AP:AP, AT2, E:E) girilir. Kırmızı kart formülasına göre bu 

formülanın farkı kırmızı kartı gösteren F:F yerine sarı kartı gösteren E:E girilmesidir. 
• Bu formüle göre 2017-2018 sezonunda 1164 kırmızı kart gösterilmiştir. Aynı şekilde aşşağıya 

kadar çekilip  otomatik cell numbering yapılır. 
• Kırmızı kart ve sarı kart sayıları bilindiği için  AX1’e isim olarak “sarı/kırmızı” girilir.  
• AX2’e formula olarak AW2/AV2 girilir daha sonra automatic cell numbering yapılır. 

 
 
Sonuç: 
 
season Kirmizi kart sari kart sari/kirmizi 
2017-
2018 39 1164 29.84615  
2016-
2017 41 1392 33.95122  
2015-
2016 59 1186 20.10169  
2014-
2015 71 1361 19.16901  
2013-
2014 53 1219 23  
2012-
2013 52 1179 22.67308  
2011-
2012 66 1154 17.48485  
2010-
2011 65 1222 18.8  
2009-
2010 68 1207 17.75  
2008-
2009 63 1176 18.66667  
2007-
2008 59 1195 20.25424  
2006-
2007 51 1204 23.60784  
     

 
 
 
 
 



 

Problem 7 

Attığı gollerin %15’i veya daha fazlası penaltı alanı dışından olan 
takımları sıralayınız. 
 
 

• Problem 6’da oluşan tablodan AT’den AX’e kadar oluşan kısım sezonlarla işimiz 
olmadığımız için silinir. 

• Verilen problem için takımın penaltı alanı dışından ve içinden attığı gol sayısına ihtiyacımız 
vardır. 

• AT1 ve AU1’e gerekli isimler verilir. 
• Daha sonra sırasıyla AT2 ve AU2 ye =SUMIF(A:A,AQ2,M:M) ve =SUMIF(A:A,AQ2,M:M) 

formülleri girilerek takımların içeriden ve dışarıdan attığı gol sayıları bulunur. 
• AV1 kısmına “oran” yazılır.  
• AV2’ye formula olarak AU2/(AU2+AT2) girilir ve daha sonra otomatik cell numbering 

yapılır. 
• AV seçilir. Data->Filter’a tıklanır. 
• AV’den filter “greater than 0.15” olarak belirlenir. 

 
Sonuç: 
 
home_team inpenalty outpenalty oran  
Manchester City 730 136 0.157044  
Chelsea 724 135 0.157159  
Liverpool 682 135 0.165239  
Tottenham Hotspur 632 133 0.173856  
West Ham United 421 78 0.156313  
Newcastle United 371 74 0.166292  
Aston Villa 365 84 0.187082  
Sunderland 335 63 0.158291  
Fulham 280 61 0.178886  
Swansea City 259 47 0.153595  
Blackburn Rovers 233 44 0.158845  
Wigan Athletic 223 48 0.177122  
Hull City 153 28 0.154696  
Portsmouth 130 35 0.212121  
Norwich City 135 25 0.15625  
Birmingham City 98 23 0.190083  
Queens Park 
Rangers 88 27 0.234783  
Blackpool 44 11 0.2  
Sheffield United 25 7 0.21875  
Charlton Athletic 27 7 0.205882  
Derby County 15 5 0.25  
       

 
 



Problem 8 

Manchester City’i ve Manchester United’ı toplam pas, toplam uzun 
pas, toplam şut denemesi, toplam gol ve toplam orta verilerini 
kullanarak Excell’in %100 stacked bar grafiğinde karşılaştırınız 
 
 

• A:A seçilip Data->Advanced seçilir. 
• Çıkan ekrandan unique records only seçilerek takımlar AQ:AQ ya yapıştırılır. 
• Daha sonra “SUMIF(A:A,AQ2,X:X)” üzerinde X:X istenilen veri için değiştirilip istenilen 

beş veri için AR-AV arasında veriler bulunur. 
(AC:AC), (AE:AE),(G:G),(D:D),(AH:AH) 

• AR-AV arasındaki veriler automatic cell numbering’e tabii tutulur. 
• Tüm takımlar için böyle bir tablo oluşur:  

 

 
 

• Radar oluşturmak için Data->Filter’dan tablo isime göre filtrelenir. Filtre girdisi olarak 
“Manchester City” ve “Manchester United” Seçilir. 
 
 
 
 
 

• Ortada kaln tüm veriler seçilip sol alta tıklanıp grafik türü olarak %100 stacked bar seçilir. 



 
Sonuç: 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

Problem 9 

Top6(Man City, Man United, Liverpool, Spurs, Chelsea, Arsenal)’nın 
galibiyet ve yenilgi istatistiklerini birbiriyle karşılaştırın. 

 
 
• Problem 8’de oluşan spreadsheet’de AQ ile AR arasına sırasıyla galibiyet ve yenilgi için iki 

kere insert yaparız 
• AR2’ye =SUMIF(A:A,AQ2,B:B) formülünü gireriz ve automatic cell numbering yaparız. 
• Aynı formülde B:B kısmını yenilgi verisi için C:C yaparak AS2’ye girer ve tekrardan 

automatic cell numbering yaparız. 
• Sonuçta EPL’de oynamış tüm takımların galibiyet ve yenilgi verileri tabloda çıkar. Biz sadece 

6 takımı istediğimiz için AQ-AR-AS yi seçerek Data->Filter’a geliriz. 
• Teams kısmına gelip filter olara istediğimiz takımların ismini gireriz ve karşımıza böyle bir 

tablo çıkar: 
 

 
 

• Tablonun üstüne gelip sağ alt kısımdan “Clustred bar” seçersek istediğimiz grafiği elde ederiz. 
Sonuç: 

 
 

 



 

Problem 10 

Manchester City ve Manchester United’ın sezon sonunda bitirdikleri 
puanları sezon-sezon karşılaştırın. 

 
 

• Stats veri setinde bir satır boyunca takımın bir sezonun elde ettiği galibiyet ve yenilgi sayısı 
yazmaktadır. Bu veriden puan verisinin elde edilmesi için ilk başta beraberlik verisinin 
bulunup daha sonra ise galibiyet-beraberlik-yenilgi verisinden puan hesabı yapılmalıdır. 

• EPL’de bir takım sezon boyunca 38 maç oynamaktadır, bu yüzden beraberlik verisi her sezon 
için “=38-galibiyet-yenilgi” ile bulunmaktadır.  

• Puan verisi ise “=galibiyet*3+beraberlik*1” ile bulunmaktadır. 
• Kolaylık için B ile C arasına “beraberlik” kısmı insert edilir. 
• C2’ye “=38-B2-D-2” formülü girelerek beraberlik bulunur ve tüm takımlar için automatic cell 

numbering yapılır. 
• Kolaylık için D ve E arasına “puan” kısmı girilir. E2’ye “=B2*3+C2*1” girilip auto cell 

numbering yapılır. 
• Olan tablo bize tüm takımları verir. A-B-C-D-E seçilip Data->Filter yapılır. 
• Filter olarak takım ismi olarak tek “Manchester City” ve “Manchester United” işaretlenir. 
• A – E ve ER(takım , puan ve sezon) kolaylık için ayrı bir sheet’e kopyalanır. 
• Tüm table seçilerek “Insert Column” kısmından “Sum of Points by season and team” seçilir. 
• Bu Pivot Chart Field oluşturur 
Sonuç: 
 

 
 



Problem 11 

Arsenal-Spurs ve Manchester United-Liverpool maçlarında maç 
başına atılan ortalama gol sayısını karşılaştırın 

 
• Bu probelm için results veri setininin kullanılması lazımdır. 
• G1’e “derbi” ismi verip G2 ve G3’e sırasıyla “ARSENAL-SPURS” ve “MANU-LIV” girilir 
• Ortalama gol için toplam gol ve toplam maç sayısı gerekmektedir. 
• Arsenal-Spurs ve Manc-Liv arasındaki toplam maçı’ı bulmak için  iki takımdan birinin ev 

sahibi olup diğerinin ise deplasmanda olduğu oyunları saymak gerekmektedir. 
• Toplam golü bulmak içinse bu sıradaki home_goals ve away_goals toplamını saymak 

gerekmektedir. 
• Arsenal-Spurs için bu formül “ =countifs(A:A,B6,B:B,B13)+countifs(B:B,B6,A:A,B13)’dür, 

anlam olarak “ev sahibi arsenal olan ve karşı takım spurs olan maç sayısı ile ev sahibi spurs 
olan ve karşı takım arsenal olan maç sayısını topla anlamına gelir. 

• B6 ve B13; B9 ve B18 olarak manu-liv için değiştirilir. 
• Toplam için formülalar sırasıyla: 
• =SUMIFS(C:C,A:A,B6,B:B,B13)+SUMIFS(D:D,A:A,B6,B:B,B13)+SUMIFS(C:C,B:B,B6,

A:A,B13)+SUMIFS(D:D,B:B,B6,A:A,B13) 
• =SUMIFS(C:C,A:A,B9,B:B,B18)+SUMIFS(D:D,A:A,B9,B:B,B18)+SUMIFS(C:C,B:B,B9,

A:A,B18)+SUMIFS(D:D,B:B,B9,A:A,B18) dır 
• Ortalama gol ise J2’ye =H2/I2 girilip auto cell numbering yapılmasıyla bulunur 
• G-H-I-J seçilerek Pivot table oluşturulur. “derbi” row’a “ortalama gol” column’a konulur. 
• Olan tablonun üzerine gelip graph oluşturulur. 
Sonuç: 

 

 
 



Problem 12 

Problem 2’de elde ettiğiniz veriyi grafiğe dökünüz. 
 
 

• Problem2 de elde ettiğimiz sheet’e açıp G ve I alanlarından yeni sheet oluşturulur. 
• Oluşan tüm tablo seçilip column bar oluşturulur. 

 
Sonuç: 

 
 

 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Problem 13 

Takımları Maç başına yaptığı ortalama pas sayısına göre sıralayınız. 
 

 
• Bunu bulmak için ilk başla Stats ile Results veri setini birleştirdiğimiz 8. Problemdeki 

verisetine döneriz. 
• Bu veri setinde AQ  ve AR verisetleri bize sırasıyla takımların ismini ve yaptıkları toplam pas 

sayısını verir. 
• Ortalama pas sayısı = yapılan pas sayısı / oynadıkları maç olduğundan takımların kaç 

sezonda oynadığı bulunup o sayı 38 ile çarpılır. 
• AR-AS arasına insert edilip toplam maç sayısı bulmaya çalışılır. Formülü 

=Countsif(A:A,AQ2)*38’dir daha sonra bu formül automatic cell numbering yapılır 
• Toplam maç ve toplam pas sayını bildiğimize göre AS-AT arasına ortalama pas diye insert 

yaparız. Formüla AR2/AS2 dir ve automatic cell numbering yapılır. 
• AQ-AT arasından Pivot Table oluşturulur. Takımlar row, ortalama değerler sum’a eklenir. 
• Daha sonra pas sırasına göre sıralarız ve grafik oluştururuz. 

 
Sonuç: 
 
 
 

 
 
 
 
 
 



 
 
 
 
 

Problem 14 

2006/2007 – 2017/2018 sezonu arası boyunca yapılan maçlarda ev 
ev sahibi galibiyeti , beraberlik ve karşı takım galibiyetini 
karşılaştırınız 
 
 

• Results veri setinde E’de bulunan result kısmı Data->Advanced “Copy to another location”, 
“Copy to G:G”  ve unique records only seçilerek kopyalanır. 

• Bu bize Home Win, Draw ve Away win listesi sunar. 
• H kısmına ise “Number” ismi verilir.  
• H2’ye =countif(E:E,G2) girilir, daha sonra automatic cell numbering yapılır. 
• İstediğimiz tablo elde edilir: 

 
 

 
 
 
 
• Daha sonra G ve H seçilerek sağ alttan Charts->Pie Chart seçilir: 
 
Sonuç: 

 



 
 
 
 
 
 

Problem 15 

Problem 7’de bulduğunuz verilerle %15 üstü yerine tüm takımları 
gösteren grafik hazırlayınız. 
 

• AP-AV arasındaki veriler ile pivot table oluşturulur. 
• Row kısmına takım isimleri values kısmına oranlar girilir. 
• Oranlar count’dan sum’a dönüştürülür 
• Pivot table’da Data->Filter’a gelinir, oranlar büyükten küçeğe göre sıralanır 
• Oluşan tablodan grafik oluşturulur. 

 
Sonuç: 
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